宝塔面板按照WordPress 主题提示:需要安装swoole加密扩展

(***主题需要swoole加密扩展,支持PHP7.2~7.4,推荐7.4)


检查当前环境
  • 操作系统 :Linux VM-4-12-centos 3.10.0-1127.19.1.el7.x86_64 #1 SMP Tue Aug 25 17:23:54 UTC 2020 x86_64
  • PHP版本 :7.4.15
  • PHP运行环境 :fpm-fcgi
  • PHP配置文件 :/www/server/php/74/etc/php.ini
  • PHP扩展安装目录 :/www/server/php/74/lib/php/extensions/no-debug-non-zts-20190902
  • PHP是否线程安全 :非线程安全
  • 是否安装swoole_loader :未安装

安装和配置Swoole Loader

1 – 点击下载 unix PHP7.4 Swoole Loader扩展文件

2 – 安装Swoole Loader

将刚才下载的Swoole Loader扩展文件(swoole_loader74.so)上传到当前PHP的扩展安装目录中:

/www/server/php/74/lib/php/extensions/no-debug-non-zts-20190902

 

3 – 修改php.ini配置(如已修改配置,请忽略此步骤,不必重复添加)

编辑此PHP配置文件:/www/server/php/74/etc/php.ini,在此文件底部结尾处加入如下配置

extension=swoole_loader74.so

注意:需要名称和刚才上传到当前PHP的扩展安装目录中的文件名一致

这里其实有都有。但是宝塔里面的配置文件是和主题要求的文件名有点不一致,所以即使安装来也要调整后才能使用。
宝塔面板按照WordPress 主题提示:需要安装swoole加密扩展
其实可以看到

extension=[v_act]swoole_loader74.so[/v_act]

这个地方不一致,
宝塔面板按照WordPress 主题提示:需要安装swoole加密扩展
修改配置文件后一定要记得重启PHP。否则不起作用。

收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

栗子博客 程序 宝塔面板按照WordPress 主题提示:需要安装swoole加密扩展 https://www.lizi.tw/program/19668.html

建筑工地上施工员,闲暇时弄个博客打发时间,

常见问题
  • 1、杰齐1.7仅适用于PHP5.2 2、需Zend支持 3、尽量使用宝塔面板 4、尽量使用Windows 系统,关关对Linux支持不太友好。
查看详情

相关文章

评论
暂无评论
宝塔面板按照WordPress 主题提示:需要安装swoole加密扩展-海报

分享本文封面