帝国7.5版本PHP Warning: Use of undefined constan解决办法

2019-10-27 0 1,553 百度已收录

帝国CMS是很强大的一个CMS,最近准备做个站点用帝国的7.5.

安装的时候是can 要双引号,现在官方还没有看到怎么处理。
安装把代码“can”双引号搞定了。结果在登陆的时候又踩坑里面了。发现下面的这些错误。我怕又踩坑里面。我就直接用文章末尾的办法,

PHP Warning:  Use of undefined constant lastip - assumed 'lastip' (this will throw an Error in a future version of PHP) in F:\wwwroot\000\e\class\adminfun.php on line 131
PHP Warning:  Use of undefined constant lastipport - assumed 'lastipport' (this will throw an Error in a future version of PHP) in F:\wwwroot\000\e\class\adminfun.php on line 131
PHP Warning:  Use of undefined constant styleid - assumed 'styleid' (this will throw an Error in a future version of PHP) in F:\wwwroot\000\e\class\adminfun.php on line 134
PHP Warning:  Use of undefined constant styleid - assumed 'styleid' (this will throw an Error in a future version of PHP) in F:\wwwroot\000\e\class\adminfun.php on line 141
PHP Warning:  Use of undefined constant userid - assumed 'userid' (this will throw an Error in a future version of PHP) in F:\wwwroot\000\e\class\adminfun.php on line 164
PHP Warning:  Use of undefined constant groupid - assumed 'groupid' (this will throw an Error in a future version of PHP) in F:\wwwroot\000\e\class\adminfun.php on line 167
PHP Warning:  Use of undefined constant userid - assumed 'userid' (this will throw an Error in a future version of PHP) in F:\wwwroot\000\e\class\adminfun.php on line 171
PHP Warning:  Use of undefined constant userid - assumed 'userid' (this will throw an Error in a future version of PHP) in F:\wwwroot\000\e\class\adminfun.php on line 172
PHP Warning:  Use of undefined constant groupid - assumed 'groupid' (this will throw an Error in a future version of PHP) in F:\wwwroot\000\e\class\adminfun.php on line 172
PHP Warning:  Use of undefined constant filechmod - assumed 'filechmod' (this will throw an Error in a future version of PHP) in F:\wwwroot\000\e\class\connect.php on line 1978

我开始的php版本是7.3
直接把PHP版本降级为7.0.就没有问题了。简单方便快捷暴力。

收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

栗子博客 程序 帝国7.5版本PHP Warning: Use of undefined constan解决办法 https://www.lizi.tw/program/6370.html

建筑工地上施工员,闲暇时弄个博客打发时间,

常见问题
  • 1、杰齐1.7仅适用于PHP5.2 2、需Zend支持 3、尽量使用宝塔面板 4、尽量使用Windows 系统,关关对Linux支持不太友好。
查看详情

相关文章

评论
1 条评论
匿名
2021年2月6日 下午9:34 回复

越来愈垃圾了

帝国7.5版本PHP Warning: Use of undefined constan解决办法-海报

分享本文封面