• dushu.tw 读书网、小说免费阅读网站

Ubuntu 18.04.4 中使用 Eclipse+PyDev 配置 Python 开发环境

软件 trishamiller2 63次浏览 已收录 0个评论 扫描二维码

先学习一下深度学习必备的编程语言 Python。工欲善其事,必先利其器。一个好用的 IDE 将会使你的学习事半功倍,下面就是我本人在 Ubuntu 18.04.4 中使用 Eclipse+PyDev 配置 Python 开发环境过程

一、前期准备

1、下载 eclipse-jee-oxygen-1-linux-gtk-x86_64.tar.gz

https://www.eclipse.org/downloads/

2、下载 jdk-8u144-linux-x64.tar.gz

http://www.oracle.com/technetwork/java/javase/downloads/index.html

这里必须下载 jdk8 版本(其他版本没有测试

二、安装 Eclipse

解压 jdk-8u144-linux-x64.tar.gz 到 /Java/eclipse/jre

解压 eclipse-jee-oxygen-1-linux-gtk-x86_64.tar.gz 到 /java/eclipse

Ubuntu 18.04.4 中使用 Eclipse+PyDev 配置 Python 开发环境

Ubuntu 18.04.4 中使用 Eclipse+PyDev 配置 Python 开发环境

配置 JDK 的环境变量,运行 sudo gedit ~/.bashrc,在文档末尾添加以下内容并保存

export JAVA_HOME=/java/eclipse/jre
export JRE_HOME=${JAVA_HOME}/jre
export CLASSPATH=.:${JAVA_HOME}/lib:${JRE_HOME}/lib
export PATH=${JAVA_HOME}/bin:$PATH

运行 source ~/.bashrc,使环境变量生效

JDK环境配置检查

运行 java -version,出现以下信息说明 JDK 环境配置成功

[linuxidc@linux:~/www.linuxidc.com]$ java -version
java version “1.8.0_241”
Java(TM) SE Runtime Environment (build 1.8.0_241-b07)
Java HotSpot(TM) 64-Bit Server VM (build 25.241-b07, mixed mode)

Ubuntu 18.04.4 中使用 Eclipse+PyDev 配置 Python 开发环境

双击 /java/eclipse 下的 eclipse 即可启动 Eclipse

三、安装 PyDev 插件

打开 Eclipse,在 Help -> Installl New Software 中点击 Add,在 Name 里面填入 PyDev,在 Location 里面填入 http://pydev.org/updates

Ubuntu 18.04.4 中使用 Eclipse+PyDev 配置 Python 开发环境

点击 OK ,选择 PyDev 下的 PyDev for Eclipse,别的都不要选

如果你的 Python 版本不是最新建议不要勾选下面的 show only the latest versions of available software 这行,去掉√即可

Ubuntu 18.04.4 中使用 Eclipse+PyDev 配置 Python 开发环境

然后一直 next ,中间会让你接受软件协议,等待安装完后重启 Eclipse

Ubuntu 18.04.4 中使用 Eclipse+PyDev 配置 Python 开发环境

测试一个代码看看

Ubuntu 18.04.4 中使用 Eclipse+PyDev 配置 Python 开发环境

四、问题解决

不知道有没有人和我一样在Eclipse中自动安装PyDev不成功,因为网络原因,所以需要手动安装PyDev。

1.第一步当然是下载PyDev了,官方下载地址跳转至此页面:http://sourceforge.net/projects/pydev/files/

选择PyDev以及要下载的版本,保存至本地。

2.解压ZIP文件

我下载的是PyDev 7.5.0.zip,解压后得到两个文件夹:features、plugins。Eclipse安装目录也有这样两个文件夹,分别将它们拷贝到Eclipse安装目录对应文件夹

这里需要指出的是,plugins里面的文件解压到dropins目录也可以的,如果发现验证PyDev不成功的情况,可以试试这个方法

3.重启Eclipse

我在重启后验证PyDev的过程中花了相当长的时间,最后在网上发现有人指出,高版本的PyDev有可能不兼容低版本的python,于是又重新下载了一个PyDev,这次终于成功了,验证方法如下:在Eclipse中点击window–preferences,在preferences窗口中,就可以看到PyDev目录了


举个栗子 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权
转载请注明原文链接:Ubuntu 18.04.4 中使用 Eclipse+PyDev 配置 Python 开发环境
喜欢 (0)
关于作者:
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到