在Ubuntu 20.04上安装Oracle Java 14

Java 14刚刚发布,如果您使用Oracle Java,请看如何在Ubuntu和派生版本中使用它。本文测试的是最新的Ubuntu 20.04 Linux。

发布公告称:

Oracle自豪地宣布Java 14的全面上市,这是个月计划中的第五​​个功能版本。两年多来的这种可预测性水平,使开发人员能够不断获得预期的更改,从而更轻松地管理他们对创新的采用。

Oracle现在为所有开发人员和企业提供Java 14。根据Oracle关键补丁更新(CPU时间表,Oracle JDK 14将至少获得两个季度的更新,然后再发布Oracle JDK15。Java15将于2020年9月全面上市,但早已提供了早期访问版本。

安装方式

要安装Oracle Java,必须完全删除开源OpenJDK,为此,您需要终端中的以下命令

请使用以下命令删除OpenJDK。

linuxidc@linuxidc:~/www.linuxidc.com$ sudo apt-get remove –purge openjdk*

清理无用的包

linuxidc@linuxidc:~/www.linuxidc.com$ sudo apt autoremove

添加 PPA linuxuprising/java

linuxidc@linuxidc:~/www.linuxidc.com$ sudo add-apt-repository ppa:linuxuprising/java

在Ubuntu 20.04上安装Oracle Java 14

更新软件包列表。

linuxidc@linuxidc:~/www.linuxidc.com$ sudo apt update

安装 java

linuxidc@linuxidc:~/www.linuxidc.com$ sudo apt install oracle-java14-installer

在Ubuntu 20.04上安装Oracle Java 14

在Ubuntu 20.04上安装Oracle Java 14

在安装Oracle Java过程中您将看到许可条款。

在Ubuntu 20.04上安装Oracle Java 14

在Ubuntu 20.04上安装Oracle Java 14

根据您的网络状况,然后开始下载jdk-14_linux-x64_bin.tar.gz包文件,可能需要一段时间

版本检测:

[linuxidc@linux:~/www.linuxidc.com]$ java –version
java 14 2020-03-17
Java(TM) SE Runtime Environment (build 14+36-1461)
Java HotSpot(TM) 64-Bit Server VM (build 14+36-1461, mixed mode, sharing)

在Ubuntu 20.04上安装Oracle Java 14

如果有多个Java版本,要将Oracle JDK14设置为默认值,运行以下命令:

linuxidc@linuxidc:~/www.linuxidc.com$ update-alternatives –config java
有 2 个候选项可用于替换 java (提供 /usr/bin/java)。

  选择      路径                                优先级  状态
————————————————————
  0            /usr/lib/jvm/java-14-oracle/bin/java  1091      自动模式
  1            /usr/lib/jvm/java-13-oracle/bin/java  1091      手动模式
* 2            /usr/lib/jvm/java-14-oracle/bin/java  1091      手动模式

要维持当前值[*]请按<回车键>,或者键入选择的编号

在Ubuntu 20.04上安装Oracle Java 14

OK,这样就安装好了Java 14。

相关:

如何在Ubuntu 18.04/18.10和Debian 9上安装Oracle Java 13  https://www.linuxidc.com/Linux/2020-02/162380.htm

收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

栗子博客 软件 在Ubuntu 20.04上安装Oracle Java 14 https://www.lizi.tw/soft/18143.html

常见问题
  • 1、杰齐1.7仅适用于PHP5.2 2、需Zend支持 3、尽量使用宝塔面板 4、尽量使用Windows 系统,关关对Linux支持不太友好。
查看详情

相关文章

评论
暂无评论
在Ubuntu 20.04上安装Oracle Java 14-海报

分享本文封面