百度编辑器Editor for ECMS

2018-02-23 0 1,402 百度已收录

UEditor深度整合帝国ECMS。UEditor提供非常完善的后端通信API接口,使得UE编辑器整合CMS项目相当简单方便。所有图片、附件、视频等文件存放目录与后台数据记录,都延续使用ECMS的存放方式。本项目将持续已插件形式更新最新的UEditor和ECMS。

使用说明

  • 下载UEditor编辑器(PHP版) [下载地址]
  • 上传到帝国/e/extend/目录下
  • 使用本项目上controller.php文件,替换编辑器自带的PHP文件(目录/e/extend/ueditor/php/controller.php)
  • 修改帝国CMS字段HTML,替换为以下代码 [字段管理方法]
<?php if(!isset($Field)){ ?>
<script type="text/javascript" src="/e/extend/ueditor/ueditor.config.js"></script>
<script type="text/javascript" src="/e/extend/ueditor/ueditor.all.min.js"></script>
<?php } ?>
<?php
/**
 * UEditor for ECMS编辑器字段配置
 * User: pkkgu 910111100@qq.com
 */
$Field    = 'newstext'; //*字段名称
$FieldVal = $ecmsfirstpost==1?"":stripSlashes($r[$Field]);
$isadmin  = 0;
if($enews=='AddNews'||$enews=='EditNews')
{ $isadmin=1; }
else
{ $FieldVal  = empty($ecmsfirstpost)?DoReqValue($mid,$Field,$FieldVal):$r[$Field]; }
?>
<script id="<?=$Field?>" name="<?=$Field?>" type="text/plain"><?=$FieldVal?></script>
<script type="text/javascript">
var ue = UE.getEditor('<?=$Field?>',{
	pageBreakTag:'[!--empirenews.page--]' //分页符
	, serverUrl: "/e/extend/ueditor/php/controller.php?isadmin=<?=$isadmin?>"
	//,toolbars:[['FullScreen', 'Source', 'Undo', 'Redo','Bold']] //选择自己需要的工具按钮名称
});
ue.ready(function(){
	ue.execCommand('serverparam', {
		'classid' : '<?=$classid?>',
		'filepass': '<?=$filepass?>',
		'userid'  : '<?=$isadmin?$logininid:$muserid?>',
		'username': '<?=$isadmin?$loginin:$musername?>',
		'rnd'     : '<?=$isadmin?$loginrnd:$mrnd?>'
	});
});
</script>

百度编辑器Editor for ECMS

#编辑内容展示

<script src="/e/extend/ueditor/ueditor.parse.min.js"></script>
<script>uParse('#newstext', {rootPath: '/e/extend/ueditor/'})</script>
<!-- 前台显示编辑器字段 -->
<div id="newstext">[!--newstext--]</div>

百度编辑器Editor for ECMS

说明

  • controller.php 后端处理文件
  • Field_html.php 帝国CMS字段HTML
  • GBK版本需要服务器支持iconv函数
  • 附件存放目录已经整合帝国CMS系统的配置
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

栗子博客 软件 百度编辑器Editor for ECMS https://www.lizi.tw/soft/4648.html

建筑工地上施工员,闲暇时弄个博客打发时间,

常见问题
  • 1、杰齐1.7仅适用于PHP5.2 2、需Zend支持 3、尽量使用宝塔面板 4、尽量使用Windows 系统,关关对Linux支持不太友好。
查看详情

相关文章

评论
暂无评论
官方客服团队

为您解决烦忧 - 24小时在线 专业服务

百度编辑器Editor for ECMS-海报

分享本文封面