• dushu.tw 读书网、小说免费阅读网站

在Windows Server 2008 R2中安装PowerShell 5

软件 举个栗子 1738次浏览 已收录 0个评论 扫描二维码

Windows Management Framework(WMF)5.1包含PowerShell 5.1。默认情况下,Windows Server 2008 R2 SP1将运行较旧的PowerShell版本2.通过将WMF 5.1下载并安装到Windows Server 2008 R2系统,我们可以将其升级到PowerShell版本5.1。


这篇文章是我们的Microsoft 70-744安全Windows Server 2016考试学习指南系列的一部分。欲了解更多相关的职位和信息,请参阅我们的完整70-744学习指南


将WMF 5.1下载到Windows Server 2008 R2系统

这也适用于Windows Server 2012和2012 R2。默认情况下,Windows Server 2016已经安装了PowerShell 5.0,所以这不是必需的。请注意,要升级Windows Server 2008 R2,您必须使用Service Pack 1(SP1)。

首先,我们将在2008 R2系统上确认PowerShell的版本。这可以通过打开PowerShell并运行$ PSVersionTable来完成,如下所示。

PS C:\> $PSVersionTable

Name                           Value
----                           -----
CLRVersion                     2.0.50727.4927
BuildVersion                   6.1.7600.16385
PSVersion                      2.0
WSManStackVersion              2.0
PSCompatibleVersions           {1.0, 2.0}
SerializationVersion           1.1.0.1
PSRemotingProtocolVersion      2.1

正如所料,我们有PowerShell版本2.0,这是该操作系统的默认值。

需要WMF 5.0或更高版本才能将Windows Server 2016中实现的刚刚够用的管理(JEA)PowerShell功能提供到较早的2008 R2 SP1操作系统中。

在我们下载并安装WMF之前,我们必须首先安装.NET Framework 4.5.2或更高版本,因为这是Windows Server 2008 R2 SP1中WMF 5.1的先决条件,默认情况下2008 R2 SP1附带.NET 3.5。您可以从这里下载更新版本的.NET:https//www.microsoft.com/net/download/framework

安装完成后,您需要执行系统重新启动才能继续。

下一步从Microsoft下载Windows Management Framework(WMF)5.1:https//www.microsoft.com/en-us/download/details.aspx?id = 54616

安装WMF后不需要重新启动系统。

一旦安装打开PowerShell并再次运行$ PSVersionTable,我们现在可以看到,PSVersion被列为5.1预期。

PS C:\> $PSVersionTable

Name                           Value
----                           -----
PSVersion                      5.1.14409.1005
PSEdition                      Desktop
PSCompatibleVersions           {1.0, 2.0, 3.0, 4.0...}
BuildVersion                   10.0.14409.1005
CLRVersion                     4.0.30319.42000
WSManStackVersion              3.0
PSRemotingProtocolVersion      2.3
SerializationVersion           1.1.0.1

现在我们将能够配置我们的Windows Server 2008 R2 SP1系统来使用足够的管理(JEA),我们将在后面的文章中介绍。

概要

通过首先更新.NET Framework,然后安装WMF 5.0或5.1,我们可以升级PowerShell版本以支持较早版本的Windows(例如Windows Server 2008 R2,2012和2012 R2)中的Just-Enough Administration(JEA)。


这篇文章是我们的Microsoft 70-744安全Windows Server 2016考试学习指南系列的一部分。欲了解更多相关的职位和信息,请参阅我们的完整70-744学习指南


举个栗子 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权
转载请注明原文链接:在Windows Server 2008 R2中安装PowerShell 5
喜欢 (0)
举个栗子
关于作者:
建筑工地上施工员,闲暇时弄个博客打发时间,
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到